通达信均价线公式

求高手帮忙编写通达信均价线公式

涨幅:=c/DYNAINFO(3);单笔换手:=v/capital*100;xx:=BARSSINCE(v>0)+1;均价线:=sum(c*v,xx)/sum(v,xx);限制:=涨幅>1.01 and 涨幅<1.04;XG:单笔换手>0.08 and cross(c,均价线) and 限制;通达信、大智慧、同花顺等经典指标集合

求通达信均线角度公式

主图叠加

十:=ATAN((MA(C,10)/REF(MA(C,10),1)-1)*100)*180/3.1415926;
二十:=ATAN((MA(C,20)/REF(MA(C,20),1)-1)*100)*180/3.1415926;
三十:=ATAN((MA(C,30)/REF(MA(C,30),1)-1)*100)*180/3.1415926;
IF(十>=30,MA(C,10),DRAWNULL),COLORRED,LINETHICK2;
IF(十<30,MA(C,10),DRAWNULL),COLORGREEN,LINETHICK2;
IF(二十>=30,MA(C,20),DRAWNULL),COLORRED,LINETHICK2;
IF(二十<30,MA(C,20),DRAWNULL),COLORGREEN,LINETHICK2;
IF(三十>=30,MA(C,30),DRAWNULL),COLORRED,LINETHICK2;
IF(三十<30,MA(C,30),DRAWNULL),COLORGREEN,LINETHICK2;

预警公式

十:=ATAN((MA(C,10)/REF(MA(C,10),1)-1)*100)*180/3.1415926;
二十:=ATAN((MA(C,20)/REF(MA(C,20),1)-1)*100)*180/3.1415926;
三十:=ATAN((MA(C,30)/REF(MA(C,30),1)-1)*100)*180/3.1415926;
T1:=十>=30 AND 二十>=30 AND 三十>=30;
XG:=T1 AND REF(T1,1)=0;

通达信分时图中 分时均价线黄线的源码怎么写

DYNAINFO(10)/DYNAINFO(8)/100;
这是当日随着时间的推移显示的即时均价,画出来的是一条直线,所以只能用不能看。

通达信均线公式

{信心操盘}
短期趋势:MA(C,LB),COLORYELLOW,LINETHICK;
中期趋势:MA(C,T),COLORYELLOW,LINETHICK2;
红升:IF(C>=短期趋势,短期趋势,DRAWNULL),CIRCLEDOT,COLORMAGENTA,LINETHICK6;
绿降:IF(C<短期趋势,短期趋势,DRAWNULL),CROSSDOT,COLORGREEN,LINETHICK5;

个股分时图的分时价位线和分时均价线是怎么画/计算的?

可以这样算,因为股票盘中是连续报价成交形成价格。也就是说股票每时每刻都有成交。

分时图的均价是如何计算出来的?

分时图是指大盘和个股的动态实时(即时)分时走势图,其在实战研判中的地位极其重要,是即时把握多空力量转化即市场变化直接根本,在这里先给大家介绍一下概念性的基础常识。
大盘指数即时分时走势图:
1) 白色曲线:表示大盘加权指数,即证交所每日公布媒体常说的大盘实际指数。
2) 黄色曲线:大盘不含加权的指标,即不考虑股票盘子的大小,而将所有股票对指数影响看作相同而计算出来的大盘指数。
参考白黄二曲线的相互位置可知:A)当大盘指数上涨时,黄线在白线之上,表示流通盘较小的股票涨幅较大;反之,黄线在白线之下,说明盘小的股票涨幅落后大盘股。B)当大盘指数下跌时,黄线在白线之上,表示流通盘较小的股票跌幅小于盘大的股票;反之,盘小的股票跌幅大于盘大的股票。
3) 红绿柱线:在红白两条曲线附近有红绿柱状线,是反映大盘即时所有股票的买盘与卖盘在数量上的比率。红柱线的增长减短表示上涨买盘力量的增减;绿柱线的增长缩短表示下跌卖盘力度的强弱。
4) 黄色柱线:在红白曲线图下方,用来表示每一分钟的成交量,单位是手(每手等于100股)。
5) 委买委卖手数:代表即时所有股票买入委托下三档和卖出上三档手数相加的总和。
6) 委比数值:是委买委卖手数之差与之和的比值。当委比数值为正值大的时候,表示买方力量较强股指上涨的机率大;当委比数值为负值的时候,表示卖方的力量较强股指下跌的机率大。
个股即时分时走势图:1) 白色曲线:表示该种股票即时实时成交的价格。
2) 黄色曲线:表示该种股票即时成交的平均价格,即当天成交总金额除以成交总股数。
3) 黄色柱线:在红白曲线图下方,用来表示每一分钟的成交量。
4) 成交明细:在盘面的右下方为成交明细显示,显示动态每笔成交的价格和手数。
5) 外盘内盘:外盘又称主动性买盘,即成交价在卖出挂单价的累积成交量;内盘主动性卖盘,即成交价在买入挂单价的累积成交量。外盘反映买方的意愿,内盘反映卖方的意愿。
6) 量比:是指当天成交总手数与近期成交手数平均的比值,具体公式为:现在总手/((5日平均总手/240)*开盘多少分钟)。量比数值的大小表示近期此时成交量的增减,大于1表示此时刻成交总手数已经放大,小于1表示表示此时刻成交总手数萎缩。
实战中的K线分析,必须与即时分时图分析相结合,才能真实可靠的读懂市场的语言,洞悉盘面股价变化的奥妙。K线形态分析中的形态颈线图形,以及波浪角度动量等分析的方法原则,也同样适合即时动态分时走势图分析。